The "YAIL compiler - D8 execution failed" error is still there

I have tried everything that has been suggested on this forum. I tried removing the package name. I tried using Build Server 2. I set the code/version name to just “1”. I added “core” components where possible. There are 3 screens in my project and I looked through them all for errors/warnings - there are none. The application works in companion. What else can I do? I just want my apk to be built.

Did you use any of extension?

Don’t try to create duplicate topic!!! :neutral_face: If one of is continuing running.

I think the issue is coming from the extension: Colors Extractor
can you please test it without the extension?

Hi @Lovely_Wallpapers

Sent me your aia privately if possible. I don’t know why is this error coming for some users, I have many projects complete or incomplete but most of the project builds successfully.

If you want to sent me aia then do this I will try and try to find the issues.


The reply button wasn’t there for some reason, creating a duplicate topic was the only way for me to respond.
Removing Colors Extractor didn’t do anything, except maybe for making the building process run for longer before the error appears.

So, You think it happened due to


How many blocks you have per screen?
What is the size of your Project file?
Let me know about your project so I can help you better.

@Lovely_Wallpapers I found the issue of app not building. The extension name Dev YB Image Loader is the main issue, just delete this component and use Async Image Loader in its place. I think your problem is solved.


1 Like

This is the solution of your issue, so please check it and tell me